python发展到今天,感觉版本有点控制不住了,同时出现多个版本python2.5,python2.7 python 3 ,同时跨越windows,mac,*inux等多个平台,还有32位,64位等不同cpu适配,这个导致python模块安装不兼容的情况越来越多

  • 最初windows上只有 python MySQLdb 官方包缺少python2.6以上支持
  • 现在已经发展到 windows 64位平台的python2.73,安装每个非集成的模块都可能失败

搜索了半天,终于发现一个好人站:http://www.lfd.uci.edu/~gohlke/pythonlibs/,它在windows上编译了大量的python 模块,同时支持32位和64位,gevent,pil,MySQLdb 我都是通过它找到合适的安装包

本文地址: http://lutaf.com/56.htm 鲁塔弗原创文章,欢迎转载,请附带原文链接